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Installation

1. Download and install the newest version of Quartus Il Web Edition Software and
ModelSim-Altera Starter Edition Software:

http://www.altera.com/products/software/quartus-ii/web-edition/qts-we-index.html

e Be sure the checkbox for Quartus Il Programmer and SignalTap Il is checked.

Create a Quartus Il Project

Once you start Quartus Il web edition. You must first create a new project by selection New
Project Wizard from the welcome screen:

1. At the Introduction page, click next.

2. Start by creating a new directory and project name, shown in Figure 1. Save it
somewhere you can access it easily (e.g., .../Documents/EEL4712/SimpleLogic). Then
click next.

& New Project Wizar, : E

Directory, Name, Top-Level Entity [page 1 of 5]

I
‘ What is the working directory for this project? i
C:/Users/hlam/Documents/EEL4712/SimpleLogic E
What is the name of this project?
SimpleLogid E

What is the name of the top-evel design entity for this project? This name is case sensitive and must exactly
match the entity name in the design file.

SimpleLogic E

Use Existing Project Settings...

< Back l[ Next > H Finish H Cancel H Help

Figure 1

3. In the next page, you would normally add design files to your project, if this is your
first lab, you don’t have any to import, so just click next.

4. In the family and device setting step, select ‘Auto device selected by the Fitter’ or
select the correct device we will be using for EEL 4712, shown in Figure 2 then click
next.



http://www.altera.com/products/software/quartus-ii/web-edition/qts-we-index.html

@ New Project Wizard

Family & Device Settings [page 3 of 3]

Select the family and device you want to taraet for compilation.

3

Device family Show in 'Available devices' list

Eamily: |Cydone IT v Package: [Anv i ]
Devices: | Al - Pin count: [Any v ]

Target device Speed grade: [A”V i ]

@ Auto device selected by the Fitter
() Spedific device selected in 'Available devices' list

Other: nfa

Available devices:

Show advanced devices

HardCopy compatible only

MName Core Voltage LEs User IfOs Memory Bits Embedded multiplier 9-bit elements PLL add
EP2CSAF256AT 1.2V 4508 153 1193038 26 2 8 |J
EP2C5AF256I8 1.2V 4608 153 119303 26 2 g
EP2CSAT144A7 1.2V 4508 39 119308 28 2 3
EP2C5F258Ce 1.2V 4508 153 119308 26 2 8
EP2C5F256C7 1.2V 4503 158 115303 20 2 3
EP2CSF256C8 1.2V 4508 158 119308 28 2 3
EP2C5F258I8 1.2V 4508 153 119308 26 2 8 il
Trmﬂmq ,... "M “_, T - | ) Ty

Companion device
HardCopy: A
Limit DSP & RAM to HardCopy device resources
< Back ] [ Mext = ] ’ Einish ] ’ Cancel l [ Help

Figure 2

5. In EDA Tool Settings, select the following (i.e., ModelSim-Altera) from the pull down
menus, shown in Table 1, and click next:

Tool Type Tool Name
Design Entry/Synthesis <None>
Simulation ModelSim-Altera
Timing Analysis <None>
Format Verification <None>

Table 1

6. On the summary page, click finish.

Adding Design Files

1. (@) From the file menu, select new. From the Menu, select the type of design file you
would like to create (in this case VHDL), then click OK, as shown in Figure 3.

Type in the VHDL code from SimpleLogic.vhd
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New Quartus II Project

4 Design Files
AHDL File
Block Diagram/Schematic File
EDIF Fie
Qsys System File
State Machine File
SystemVerilog HDL File
Td Script File
VHDL File
Veriog HDL File

4 Memory Fies
Hexadedmal (Intel-Format) File
Memory Initialization Fle

4 Verification/Debugging Files
In-System Sources and Probes File
Logic Analyzer Interface Fle
SignalTap II Logic Analyzer File

4 Other Files
AHDL Indude File
Block Symbal Fle
Chain Description Fle
Synopsys Design Constraints File
Text File

oK ][ T H Help

Figure 3
1. (b) Alternatively, you can add the file (SimpleLogic.vhd) to the project (without having
to type it in:

Click Project>Add/Remove File from Project ...
Browse to the directory and select SimpleLogic.vhd
Click Add and then OK

2. If necessary, confirm that the design file was added to the current project, by click from
the top menu: Project > Add Current File to Project.

Setting Up the EDA Simulator Execution Path

To run an EDA simulator (e.g. Modelsim-Altera) automatically from the Quartus Il software using
the NativeLink feature, specify the path to your simulation tool by performing the following steps:

1. On the Tools menu, click Options. The Options dialog box appears.
2. Inthe Category list, under the General category, select EDA Tool Options.

3. The Options window should look like Figure 4. In the Modelsim-Altera entry, the location
of executable should be something like “C:\altera\13.0sp1l\modelsim_ase\win32aloem”.

4. If not, then browse to the directory containing the executable of the Modelsim-Altera
simulator. (Again, path should be like “C:\altera\13.0spl\modelsim_ase\win32aloem™.)

5. Click OK.




Compiling the Design
Once you have all the design files you need in place, you are ready to compile:
1. On the top menu, select: Processing = Start Compilation.
2. The message window below will show compilation status, and you will also be shown a

compilation report window. If the design compiles successfully, you can close out the
report.

&} Options | =

Category:

4 General EDA Tool Options

EDA Tool Options
Fonts Spedify the location of the tool executable for each third-party EDA tool:

Headers & Footers Settings

= EDA Tool Location of Executable
4 Internet Connectivity
Motifications LeonardoSpectrum E]

Libraries Precision Synthesis [:]

License Setup )

Preferred Text Editor Synpiify [:]

Processing Synplify Pro D

Tooltip Settings Active-HOL D
4 Messages

Colors Riviera-PRO (o]

Fonts ModelSim D
4 Text Editor )

Colars Questasim D

Fonts ModelSim-Altera C:\alteral13.0sp1'modelsim_ase\win32aloem E]

Autocomplete Text NCSim E]

[7] Use NativeLink with a Synplify/Synplify Pro nodedocked license

0K ” Cancel ” Help

Figure 4




Compilation in ModelSim-Altera

Now that you have created and compiled the project in Quartus Il. You are ready to use
ModelSim to perform the testbench simulations, but first you need to compile your design files
in ModelSim

1. Invoke ModelSim from Quartus: Tools = Run Simulation Tool - RTL Simulation
2. On ModelSim open the compile window by clicking Compile > Compile
3. Compile the following files:
a. SimpleLogic.vho (should be in the simulation/modelsim directory)
b. SimpleLogic_tb.vhd (Provided to you in LablvhdlIFiles.zip and placed by you in
some directory)
4. Click Done and open the library view if it’s not already open (by selecting View ->
Library) and verify the red circled portions as shown in Figure 5 are there.
5. If there are errors, try compiling again because an incorrect compilation order can cause
this problem. If there are errors in the testbench, you likely didn’t name your I/O
correctly in your Quartus design file (SimpleLogic.vhd).

I Library g iH A X
Mame T |Type -
" |

Entitv
Appears after you compile

Simplelogic tb.vhd
Architec |

Appears after you compile

vital 2000
SimpleLogic.vho

+Hi
-k} verilog
i"ﬂl SYNOpSys Ciorary
ﬂ—ﬂl sv_std Library
M strativy_wer (empty) Library
M strativy_pcie_hip_ver (empty) Library
ﬂ—m stratixy_pcie_hip Library
M stratixy_hssi_ver (empty) Library
i"ﬂl stratixy_hssi Library
ﬂ—ﬂl stratixy Library
ﬂ—_[i]_ stratiiv_ver Library
ﬂ—m strativiv_pde_hip_wver ) Library
ﬂ—ﬂl stratixiv_pde_hip Library
ﬂ—ﬂl strativiv_hssi_ver Library
i"ﬂl stratixiv_hssi Library
i stratixiv Library
Figure 5




Understanding a Testbench File

Testbench files are used to test your design files as against a set of input test signals. Input test
signals are generated and applied to the unit under test (UUT) within the test bench. Figure 6 is a
testbench file we used for this tutorial.

=F- David Tietz
L—— University of Florida

--TestBench Template
LIBRARY ieee;
USE ieee.std logic 1164.all;

USE iees.numeric_std.all;

s IE e RS, QT FE R SO T

9 HBENTITY SimpleLogic tb is
10 LEND simpleLogic tb;

Declaring all input and
output test signals

12 ——Component Declaration

13 BARCHITECTURE behavior of SimpleLogje”tb is

14

15 SIGNAL A,B,C,D : std logics

16 SIGNAL Z : std logics

17

18 HBEGIN -- TB

19

20 ——Component Instatiation

21 3 UUT : ENTITY work.SimpleLogic

22 B PORT MAP (

23 A =>n, Mapping input test signals
24 B => B, ]

25 c =, to component signals of
26 D =>1D

27 2=> 7 UUT (i.e., SimpleLogic)
28 )

29

30

31 —-- Test Bench Statements

32

33 ——Stimulus process

34 @ stim proc: process

35 begin .

36 --Set initial values Setting values to
37 A<= '0"; . .

38 B <= t0'; / input test signals
39 Cc<="'0"';

40 D<= "'0';

41

42 wait for 100ns;

43 --do something

Figure 6

A<= "1";

B <= '0';

c<="'0";

D<= '0';

wait for 200ns;

—-do something

A 111 Wait between
B <= 1'1%; changing input
C <= '0"; ging Inp
D<= '0"; values

wait for 300ns;

--do something

A<= "'0";
B <= "'0";
c<="'1";
D<= "'1";

wait for 400ns;
——do something

A<= "1";
B <= "'1";
C <= "'1";
D<= '0";

wait for 500ns;
REPORT "SIMULATION FINISHED!";
wait;

END PROCESS;
--End Test Bench

“END?

For future designs, you will need to make or modify the above testbench file to fit the needs of
the design you are trying to simulate. You will need to declare the test signals you will use, port
map them to correct component signals from the Quartus design, and then setup the actual signal

transitions.




Running a Functional Simulation

In a functional simulation, you will simulate your design based on a functional stand point. In
other words, delays through the system will not be taken into account. To run a functional
simulation:

1.
2.
3.

Click Simulate - Start Simulation.
On the Design tab select work = SimpleLogic_tb, which is the testbench. Click OK.

Two simulation windows should load: Object window and Wave window. If not, you
can always load them yourself by clicking the View menu and checking the appropriate
window.

Generally you want to display all the test signals in the Wave window. To do so, click in
the Objects window

e Click Add->To Wave -> Signals in Region
Alternatively, you can display only selected signals in the Wave window:

e In the Objects window, select the signals you would like to monitor and drag them
into the Wave window (or copy and paste).

5. Click Simulate = Run = Run -All.
6. You can use ‘Ctrl +* and ‘Ctrl -* to zoom in and out. Figure 7 shows the results of the
simulation.
|I L ! ) H edsion ’.__ vy ‘
pa| Wave i - & x|

[simplelogic_tb/d

4 DN

f-A Transcript | gm| Wave l $a Objects lsﬁ Processes l Ji}, Library l|§| Project l sim ‘ RE
0 ps to 1865573 ps |Project : SimpleLogic_ms |Now: 1,500 ns Delta: 1 sim: fsimplelogic_tb
Figure 7




Running a Timing Simulation

In a timing simulation, you will simulate your design based on a timing stand point. In other
words, delays through the system will be included and will affect the performance of your
design. To run a timing simulation:

1. Make sure the simulation currently running is complete by clicking Simulation=>End
Simulation.

2. Quartus creates an .sdo file to annotate simulation with actual propagation delays. To
include this in your ModelSim project:

a.
b.

Select the SDF tab (on the dialog box that comes up after Start Simulation).

Add the SimpleLogic.sdo file that is in the quartus_project/simulation/modelsim
directory.

This should be same directory as the .vho file that you previously added.
In the “Apply to Region” text box, make sure to type /UUT (this is the same label
used in the testbench file for that region of component instantiation).

3. On the Design tab select work->SimpleLogic_tb, which is the testbench. Click OK. Three
simulation screens will load.

4. In the Objects window, select the signals you would like to monitor and drag them into
the Wave view.

5. Click Simulate = Run = Run -All.

6. Figure 8 shows the results of the timing simulation.

[T am

‘ 0 ps to 1865573 ps ‘Project : SimpleLogic_ms ‘Now: 1,500 ns Delta: 1 sim: fcydoneii_atom_pack

Figure 8
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